openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tomas Forsman (JIRA)" <>
Subject [jira] [Closed] (OPENJPA-2202) axiom bundles does not have MANIFEST.MF as first entry of the zip
Date Fri, 25 May 2012 14:28:23 GMT


Tomas Forsman closed OPENJPA-2202.

    Resolution: Invalid

Created the issue on wrong project, this should go to axiom
> axiom bundles does not have MANIFEST.MF as first entry of the zip
> -----------------------------------------------------------------
>                 Key: OPENJPA-2202
>                 URL:
>             Project: OpenJPA
>          Issue Type: Bug
>         Environment: Using axiom version 1.2.13 (could not find it in the "Affects Version/s"
> Karaf 2.2.6
>            Reporter: Tomas Forsman
> The problem occurs when trying to install axiom-impl (or axiom-dom) from within a karaf-feature
> <feature name="axiom-test" version="1.0.0-SNAPSHOT">
>         <!-- possible that other bundles are needed here, this is just an example
>         <bundle></bundle>
>         <bundle></bundle>
>         <bundle></bundle>
> </feature>
> Typeing "feature:install axiom-test" from within karaf will give the following error:
> "Error executing command: Manifest not present in the first entry of the zip"
> OpenJPA had the same issue and has solved it:
> "This issue only shows up when you do a features:install because the
> features service is looking at the MANIFEST.MF right upfront to
> determine if it needs to install the bundle or if there's already a
> suitable bundle available in the container." --

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message