openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Albert Lee (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OPENJPA-1728) SchemaTool is not using UTF-8 for content in generated XML files
Date Fri, 03 Feb 2012 17:03:53 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-1728?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Albert Lee updated OPENJPA-1728:
--------------------------------

    Affects Version/s: 2.2.0
                       2.1.1
        Fix Version/s:     (was: 2.2.0)
                       2.3.0

Move fix version to 2.3.0 in preparation for 2.2.0 release.
                
> SchemaTool is not using UTF-8 for content in generated XML files
> ----------------------------------------------------------------
>
>                 Key: OPENJPA-1728
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1728
>             Project: OpenJPA
>          Issue Type: Bug
>          Components: jdbc
>    Affects Versions: 1.2.2, 1.3.0, 2.0.0, 2.1.1, 2.2.0
>            Reporter: Donald Woods
>            Assignee: Donald Woods
>             Fix For: 2.3.0
>
>
> Discovered while working on OPENJPA-1724 that the SchemaTool is generating XML files
marked as encoding="UTF-8", but the code is actually using a FileWriter which uses the JVM
locale instead of a OutputStreamWriter set to UTF-8 for the output.
> This is not a simple switch of class usage, as the SchemaTool supports an APPEND flag,
which FileWriter supports, but OutputStreamWriter does not....

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message