openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Nowosatka (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OPENJPA-2084) Upgrade Derby dependency to 10.8.x
Date Wed, 14 Dec 2011 21:21:30 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-2084?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jacob Nowosatka updated OPENJPA-2084:
-------------------------------------

    Attachment: OPENJPA-2084.patch

I updated the derby dependency to derby 10.8.2.2 and ran the tests. In all cases, there were
no issues or regressions to speak of. I attached a patch with the fix, more or less for formality
since the change is a very small one. :-)
                
> Upgrade Derby dependency to 10.8.x
> ----------------------------------
>
>                 Key: OPENJPA-2084
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2084
>             Project: OpenJPA
>          Issue Type: Improvement
>          Components: build / infrastructure, jdbc
>    Affects Versions: 2.2.0
>            Reporter: Kevin Sutter
>            Assignee: Jacob Nowosatka
>             Fix For: 2.2.0
>
>         Attachments: OPENJPA-2084.patch
>
>
> As we continue to explore the needs for Java 7 support with OpenJPA, it's been determined
that our current dependency on Derby 10.5.x is not sufficient.  Derby 10.8.x is the required
level in order to support Java 7.  We should be able to upgrade this dependency just from
a runtime perspective -- even before we make other changes in support of Java 7.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message