openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2091) update docbook maven plugin
Date Fri, 09 Dec 2011 18:00:41 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2091?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13166371#comment-13166371
] 

Mark Struberg commented on OPENJPA-2091:
----------------------------------------

Was pretty hard to get this working, but I think I'm on the right track now.

I upgraded the docbkx plugin to 2.0.13 (latest version) and experienced quite a few errors
 - glad that there was a comment in the pom telling me that I should expect troubles ;)

First of all, xml.apche.org got moved to xmlgraphics.apache.org. This was done between fop-0.94
and fop-0.95. Current version is fop-1.0 which we now use.
This can be solved by using the following in the xslt:

    <xsl:param name="fop.extensions" select="0"/>
    <xsl:param name="fop1.extensions" select="1"/>

There was also a docbook error which didn't get detected by the old version but bails out
with an error now. The new version is a bit picky when it comes across tables which have more
columns than specified via <tgroup cols="n">

                
> update docbook maven plugin
> ---------------------------
>
>                 Key: OPENJPA-2091
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2091
>             Project: OpenJPA
>          Issue Type: Task
>          Components: build / infrastructure
>    Affects Versions: 2.2.0
>            Reporter: Mark Struberg
>            Assignee: Mark Struberg
>             Fix For: 2.2.0
>
>
> I'm getting a build error when trying to build the openjpa docbook 
> [WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is missing, no dependency
information available
> [WARNING] Failed to retrieve plugin descriptor for org.eclipse.m2e:lifecycle-mapping:1.0.0:
Plugin org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could not be resolved:
Failed to read artifact descriptor for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> $> mvn versions:show-plugin-updates
> shows that the docbook plugin is pretty outdated. 
> [INFO] The following plugin updates are available:
> [INFO]   com.agilejava.docbkx:docbkx-maven-plugin ............ 2.0.7 -> 2.0.13
> We should try to update to the latest bugfix version. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message