openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-2084) Upgrade Derby dependency to 10.8.x
Date Thu, 15 Dec 2011 16:02:30 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-2084?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13170306#comment-13170306
] 

Kevin Sutter commented on OPENJPA-2084:
---------------------------------------

Hi Jake, thanks for the patch.  The update you proposed looks good from a purely dependency
and testing perspective.  But, what about the documentation and other scripts?  At a minimum,
we would like to update the documentation to show that we now support the 10.8.x version of
Derby.  And, some of the other testing and build scripts call out and reference specific versions
of Derby.  Do any of these need to be updated?  I'd do a search on "derby" and "10.5" to see
the type of references I am referring to.  Let me know if additional updates are required
for this patch.  Thanks!
                
> Upgrade Derby dependency to 10.8.x
> ----------------------------------
>
>                 Key: OPENJPA-2084
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-2084
>             Project: OpenJPA
>          Issue Type: Improvement
>          Components: build / infrastructure, jdbc
>    Affects Versions: 2.2.0
>            Reporter: Kevin Sutter
>            Assignee: Jacob Nowosatka
>             Fix For: 2.2.0
>
>         Attachments: OPENJPA-2084.patch
>
>
> As we continue to explore the needs for Java 7 support with OpenJPA, it's been determined
that our current dependency on Derby 10.5.x is not sufficient.  Derby 10.8.x is the required
level in order to support Java 7.  We should be able to upgrade this dependency just from
a runtime perspective -- even before we make other changes in support of Java 7.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message