openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick (JIRA)" <>
Subject [jira] [Assigned] (OPENJPA-2031) Unable to import maven projects with m2e version 1.0
Date Mon, 18 Jul 2011 20:33:57 GMT


Michael Dick reassigned OPENJPA-2031:

    Assignee: Jacob Nowosatka

> Unable to import maven projects with m2e version 1.0
> ----------------------------------------------------
>                 Key: OPENJPA-2031
>                 URL:
>             Project: OpenJPA
>          Issue Type: Improvement
>            Reporter: Jacob Nowosatka
>            Assignee: Jacob Nowosatka
>            Priority: Minor
>         Attachments: OPENJPA-2031.patch.txt
> Using m2e v1.0, importing maven projects will cause errors such as:
> maven-dependency-plugin(goals "copy-dependencies", "unpack") is not supported by m2e
> Plugin execution not covered by lifecycle configuration:
> The reason for these errors is described in the link.
> A solution to this problem using the method set forth by the wiki is attached. The patch
applies to the pom.xml in openjpa-parent.
> This should solve any maven related problem. However, there still may be errors in the
source of openjpa-kernel and openjpa-openbooks. The first is solved by adding target/generated-sources/javacc
to the build path of openjpa-kernel. The second is done in the same way, except with target/generated-metamodel/java
to the build path of openjpa-openbooks.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message