openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Heath Thomann (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OPENJPA-1665) Problems when using auto incrementing colums that start at zero
Date Tue, 22 Mar 2011 20:24:05 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-1665?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13009822#comment-13009822
] 

Heath Thomann commented on OPENJPA-1665:
----------------------------------------

Committed changes to 2.0.x under revision 1084264.

> Problems when using auto incrementing colums that start at zero 
> ----------------------------------------------------------------
>
>                 Key: OPENJPA-1665
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1665
>             Project: OpenJPA
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Rick Curtis
>            Assignee: Rick Curtis
>             Fix For: 2.1.0
>
>
> This issue was reported on the users mailing list[1].
> The issue is that it is possible when using auto generated ids that there is a current
entity in the persistence context that has an id of zero, and by default when a new entity
is created it also has an id of zero. When persisting the second entity, OpenJPA incorrectly
detects that there are multiple entities with the same id in the context even though the new
id doesn't have an id from the database yet.
> [1]http://openjpa.208410.n2.nabble.com/An-object-of-type-src-StatusUpdate-with-oid-0-already-exists-in-this-context-another-cannot-be-persi-td5030272.html#a5030272

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message