openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Donald Woods (JIRA)" <j...@apache.org>
Subject [jira] Created: (OPENJPA-1861) Update maven plugins used in builds to support Maven 3.0
Date Fri, 29 Oct 2010 13:58:21 GMT
Update maven plugins used in builds to support Maven 3.0
--------------------------------------------------------

                 Key: OPENJPA-1861
                 URL: https://issues.apache.org/jira/browse/OPENJPA-1861
             Project: OpenJPA
          Issue Type: Improvement
          Components: build / infrastructure
    Affects Versions: 2.0.0
            Reporter: Donald Woods
            Assignee: Donald Woods
            Priority: Minor
             Fix For: 2.1.0


Apache Maven 3.0 has been released and we have some build failures when using it, like -
openjpa-lib - multiple versions of Ant being used in the builds.  Fix is to upgrade some old
ant-1.6.5.jar usage to match the 1.7.1 used by the maven-antrun-plugin and set an exclusion
on one dependency that is pulling in ant-1.5
openjpa-all - shade plugin trying to jar up the target/classes directory when it shouldn't.
 Fix is to remove the maven-jar-plugin usage from the openjpa-all/pom.xml
Also, will be upgrading all the other maven plugins to the latest levels, as some newer releases
include Maven 3.0 fixes or additional settings.  Will verify the builds still work with Maven
2.2.1 and 3.0.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message