openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: Enforcer rules within Eclipse
Date Wed, 22 Sep 2010 14:49:38 GMT
To be honest, I don't know how I cleaned it up, but this Eclipse Enhancer
error is now gone.  I had been using the m2eclipse plugin and thinking that
maybe I needed to upgrade, I tried to upgrade to version 0.10.
Unfortunately, this required the removal of 0.9.8.  When I tried to
uninstall 0.9.8, I got several popup errors about OOM and NPE errors --
which then required a restart of Eclipse.  After several restarts due to
continued experimentation, my build environment is now clean...  And, I'm
still using 0.9.8 of the m2eclipse plugin...  Go figure...

Kevin

On Tue, Sep 21, 2010 at 6:18 PM, Kevin Sutter <kwsutter@gmail.com> wrote:

> Hi,
> I'm getting an error within Eclipse concerning Enforcer rules.
>
> Description    Resource    Path    Location    Type
> Some Enforcer rules have failed. Look above for specific messages
> explaining why the rule failed.    TRUNK-openjpa-lib        line 1    Maven
> Problem
>
> I know about enforcing the maven level and the java levels, but all of my
> TRUNK-openjpa-* projects have the same IBM JDK 6 specified.  For some
> reason, openjpa-lib doesn't like the Enforcer rules specified.  Is there a
> minimum JDK 6 level that is required?  Everything builds just fine from the
> command line.  Any ideas?  Thanks.
>
> Kevin
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message