openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dick <michael.d.d...@gmail.com>
Subject Re: Period error with loading openbooks inventory
Date Wed, 25 Aug 2010 15:17:44 GMT
I tried with the latest code (as of yesterday) and I wasn't able to
reproduce it.

I did make a couple of classpath changes and I only tried with Derby. Were
you using MySQL by any chance?

-mike

On Tue, Aug 24, 2010 at 8:53 AM, Kevin Sutter <kwsutter@gmail.com> wrote:

> Hi,
> I'm using the OpenBooks sample for a demo and I periodically hit an
> Optimistic Lock Exception while loading the database:
>
> ant -f run.xml load
>
> This doesn't happen every time, but often enough to have me post this
> question and see if this is a known issue.
>
>     [java] Caused by: <openjpa-2.1.0-SNAPSHOT-r422266:988223M nonfatal
> store error> org.apache.openjpa.persistence.OptimisticLockException: An
> optimistic lock violation was detected when flushing object instance
> "openbook.domain.Inventory-U0205-90" to the data store.  This indicates
> that
> the object was concurrently modified in another transaction.
>     [java] FailedObject: openbook.domain.Inventory-U0205-90
>
> Any ideas?
>
> Kevin
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message