openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Bauer <techhu...@gmail.com>
Subject Re: [DISCUSS] Time to finally drop Java SE 5 support starting the 2.1 codebase?
Date Mon, 16 Aug 2010 18:46:09 GMT
+1 removing official support of 1.5 on trunk.

Would trunk continue to build 1.5 level binaries or would it switch to 1.6?
Is there any major benefit in building 1.6 level binaries?  If not, there's
a good chance trunk *may* continue to work with JRE 1.5 if trunk uses a 1.5
level build.

-Jeremy

On Mon, Aug 16, 2010 at 12:27 PM, Donald Woods <dwoods@apache.org> wrote:

> OK, I know we've had this discussion for the 2.0 release, but now that
> you cannot receive free support updates to Sun/Oracle Java SE 5, I don't
> see why we would continue supporting it in the trunk code that will
> eventually become the 2.1 release.  It is definitely a headache to
> continue building with 1.6 but support 1.5 for runtime and verify it by
> running our JUnits on 1.5.  Also, we have the 2.0.x branch to support
> 1.5 users, so the debate about not allowing 1.5 users to move up to JPA
> 2.0 support no longer applies.
>
>
> Thoughts?
>
> -Donald
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message