openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dick <michael.d.d...@gmail.com>
Subject Re: OpenJPA test suite error
Date Fri, 07 May 2010 18:40:47 GMT
Hi John,

You need to set -DfailIfNoTests=false on the command line. Otherwise maven
will compile the first module (openjpa-lib), notice that there are no tests
and stop executing.

Unfortunately the documentation was written with an older version of Maven
which didn't require -DfailIfNoTests (I think that was new sometime around
maven 2.0.8).

I'll update the doc. Thanks for letting us know,
-mike

2010/5/7 Ян Программист <webautomator@gmail.com>

> $ mvn test -Dtest=TestPersistence -Dopenjpa.loglevel=TRACE
> [INFO] Scanning for projects...
> [INFO] Reactor build order:
> [INFO]   OpenJPA Parent POM
> [INFO]   OpenJPA Utilities Library
> [INFO]   OpenJPA Kernel
> [INFO]   OpenJPA JDBC
> [INFO]   OpenJPA Persistence
> [INFO]   OpenJPA Persistence JDBC
> [INFO]   OpenJPA Persistence Locking Tests
> [INFO]   OpenJPA XML Store
> [INFO]   OpenJPA Slice
> [INFO]   OpenJPA Aggregate Jar
> [INFO]   OpenJPA Aggregate Jar with Dependencies
> [INFO]   OpenJPA Project Docs and Assemblies
> [INFO]   OpenJPA Examples
> [INFO]   OpenJPA Integration Tests
> [INFO]   OpenJPA Integration Tests - Daytrader
> [INFO]   OpenJPA Integration Tests - Examples
> [INFO]   OpenJPA Integration Tests - JPA TCK
> [INFO]   OpenJPA Integration Tests - Bean Validation
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building OpenJPA Parent POM
> [INFO]    task-segment: [test]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] [enforcer:enforce {execution: default}]
> [INFO] Setting property: classpath.resource.loader.class =>
> 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
> [INFO] Setting property: velocimacro.messages.on => 'false'.
> [INFO] Setting property: resource.loader => 'classpath'.
> [INFO] Setting property: resource.manager.logwhenfound => 'false'.
> [INFO] [checkstyle:checkstyle {execution: default}]
> [INFO] Source directory does not exist - skipping report.
> [INFO] Setting property: classpath.resource.loader.class =>
> 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
> [INFO] Setting property: velocimacro.messages.on => 'false'.
> [INFO] Setting property: resource.loader => 'classpath'.
> [INFO] Setting property: resource.manager.logwhenfound => 'false'.
> [INFO] [remote-resources:process {execution: default}]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building OpenJPA Utilities Library
> [INFO]    task-segment: [test]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] [enforcer:enforce {execution: default}]
> [INFO] [checkstyle:checkstyle {execution: default}]
> [INFO] Starting audit...
> Audit done.
>
> [WARNING] Unable to locate Source XRef to link to - DISABLED
> [INFO] [remote-resources:process {execution: default}]
> [INFO] [resources:resources {execution: default-resources}]
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] Copying 9 resources
> [INFO] Copying 3 resources
> [INFO] [compiler:compile {execution: default-compile}]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [antrun:run {execution: set subversion revision}]
> [INFO] Executing tasks
>     [echo] Revision: exported
>     [echo] OpenJPA version: 2.0.0-beta3
> [INFO] Executed tasks
> [INFO] [resources:testResources {execution: default-testResources}]
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
>
> [INFO] Copying 8 resources
> [INFO] Copying 3 resources
> [INFO] [compiler:testCompile {execution: default-testCompile}]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [surefire:test {execution: default-test}]
> [INFO] Surefire report directory:
>
> /home/webautomator/apache-openjpa-2.0.0-beta3-source/openjpa-lib/target/surefire-reports
>
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> There are no tests to run.
>
> Results :
>
> Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
>
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] No tests were executed!  (Set -DfailIfNoTests=false to ignore this
> error.)
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 25 seconds
> [INFO] Finished at: Fri May 07 20:41:05 EEST 2010
> [INFO] Final Memory: 50M/120M
> [INFO]
> ------------------------------------------------------------------------
>
> John
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message