openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Sutter <kwsut...@gmail.com>
Subject Re: compile error
Date Mon, 24 May 2010 14:56:33 GMT
Hi Oliver,
Our POM specifies a dependency on 8.4-701.jdbc3.  I just verified that
LargeObject.truncate(int) does exist in this package.  My guess is that you
have an older version of the Postgres dependency and maven is not properly
updating this dependency.  Have you tried the -U option when doing the mvn
build?  If that doesn't work, maybe you should wipe out your maven
repository and have it download the proper binaries again.  This dependency
on the Postgres binaries has been in our POM for quite a long time, so my
guess is that there's a problem in your development environment somewhere.

Good luck,
Kevin

On Sat, May 22, 2010 at 10:33 AM, Oliver Krohne <okrohne@yahoo.de> wrote:

> hi,
>
> i would like to build openjpa2.0.0 but the jdbc part gives a compile error:
> [ERROR] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Compilation failure
> /Users/oliver/Documents/workspace/openjpa-trunk/openjpa/openjpa-jdbc/src/main/java/org/apache/openjpa/jdbc/sql/PostgresDictionary.java:[495,22]
> cannot find symbol
> symbol  : method truncate(int)
> location: class org.postgresql.largeobject.LargeObject
>
> I also tried to build the trunk which has the same issue.
>
> I use macos 10.6  with JDK  "1.6.0_17" and maven 2.2.0
>
> Thanks in advance for any hints,
>
> Oliver

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message