openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dick <michael.d.d...@gmail.com>
Subject Re: The openjpa-xxxx-5 modules are not built using an "older" Maven version.
Date Mon, 19 Apr 2010 15:24:17 GMT
Hi Heath,

I have the same problem with Maven 2.0.10 on Linux, FWIW. With Maven 2.2.0
it works. I remember it working with Maven 2.0.8 as well but I might have
been using  different JDK then.

I'm glad you found a workaround. Unfortunately it looks like we need to
update the documentation at least for building 1.0.x

-mike


On Fri, Apr 16, 2010 at 12:11 PM, Heath Thomann <jpaheath@gmail.com> wrote:

> Hello!  I've had an issue when building the 1.0.x code.  That is, when I
> perform the following command:
>
> mvn clean install
>
> I've found that the openjpa-xxxx-5 modules are not build.  To get maven to
> build the modules, I've had to use the '-Pjdk1.5' option, like this:
>
> mvn clean -Pjdk1.5 install
>
> I have the following in my environment:
> OpenJPA version 1.0.x
> Maven version 2.0.10
> Sun JDK version 1.5.0_22
>
> If I move up to Maven version 2.2.1 the openjpa-xxxx-5 modules appear to
> build fine (with or without the '-Pjdk1.5' option).  However, it is only a
> requirement that a user use Maven 2.0.9 or newer so Maven 2.0.10 should
> build the openjpa-xxxx-5 modules with or without the '-Pjdk1.5' option.
>  Has
> anyone experienced similar issues?
>
> Thanks,
>
> Heath Thomann
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message