openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Heath Thomann <jpahe...@gmail.com>
Subject The openjpa-xxxx-5 modules are not built using an "older" Maven version.
Date Fri, 16 Apr 2010 17:11:38 GMT
Hello!  I've had an issue when building the 1.0.x code.  That is, when I
perform the following command:

mvn clean install

I've found that the openjpa-xxxx-5 modules are not build.  To get maven to
build the modules, I've had to use the '-Pjdk1.5' option, like this:

mvn clean -Pjdk1.5 install

I have the following in my environment:
OpenJPA version 1.0.x
Maven version 2.0.10
Sun JDK version 1.5.0_22

If I move up to Maven version 2.2.1 the openjpa-xxxx-5 modules appear to
build fine (with or without the '-Pjdk1.5' option).  However, it is only a
requirement that a user use Maven 2.0.9 or newer so Maven 2.0.10 should
build the openjpa-xxxx-5 modules with or without the '-Pjdk1.5' option.  Has
anyone experienced similar issues?

Thanks,

Heath Thomann

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message