Return-Path: Delivered-To: apmail-openjpa-dev-archive@www.apache.org Received: (qmail 91308 invoked from network); 8 Mar 2010 16:26:12 -0000 Received: from unknown (HELO mail.apache.org) (140.211.11.3) by 140.211.11.9 with SMTP; 8 Mar 2010 16:26:12 -0000 Received: (qmail 7431 invoked by uid 500); 8 Mar 2010 16:25:48 -0000 Delivered-To: apmail-openjpa-dev-archive@openjpa.apache.org Received: (qmail 7372 invoked by uid 500); 8 Mar 2010 16:25:48 -0000 Mailing-List: contact dev-help@openjpa.apache.org; run by ezmlm Precedence: bulk List-Help: List-Unsubscribe: List-Post: List-Id: Reply-To: dev@openjpa.apache.org Delivered-To: mailing list dev@openjpa.apache.org Received: (qmail 7364 invoked by uid 99); 8 Mar 2010 16:25:48 -0000 Received: from athena.apache.org (HELO athena.apache.org) (140.211.11.136) by apache.org (qpsmtpd/0.29) with ESMTP; Mon, 08 Mar 2010 16:25:48 +0000 X-ASF-Spam-Status: No, hits=-2000.0 required=10.0 tests=ALL_TRUSTED X-Spam-Check-By: apache.org Received: from [140.211.11.140] (HELO brutus.apache.org) (140.211.11.140) by apache.org (qpsmtpd/0.29) with ESMTP; Mon, 08 Mar 2010 16:25:47 +0000 Received: from brutus.apache.org (localhost [127.0.0.1]) by brutus.apache.org (Postfix) with ESMTP id 25FE1234C052 for ; Mon, 8 Mar 2010 16:25:27 +0000 (UTC) Message-ID: <1557341319.137971268065527151.JavaMail.jira@brutus.apache.org> Date: Mon, 8 Mar 2010 16:25:27 +0000 (UTC) From: "Michael Dick (JIRA)" To: dev@openjpa.apache.org Subject: [jira] Updated: (OPENJPA-1118) code changes towards broader use of JDK5 features In-Reply-To: <1428995468.1244127067637.JavaMail.jira@brutus> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-JIRA-FingerPrint: 30527f35849b9dde25b450d4833f0394 [ https://issues.apache.org/jira/browse/OPENJPA-1118?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Michael Dick updated OPENJPA-1118: ---------------------------------- Attachment: OPENJPA-1118.diff.txt Many of the changes have already been done under separate issues. The major outstanding part is to replace Numbers.valueOf() with JRE factory methods. Autoboxing uses Integer.valueOf() automatically and since it makes the code easier to read (subjective) and it's significantly easier to make the changes I've gone that route. Attaching a patch with the proposed changes. > code changes towards broader use of JDK5 features > ------------------------------------------------- > > Key: OPENJPA-1118 > URL: https://issues.apache.org/jira/browse/OPENJPA-1118 > Project: OpenJPA > Issue Type: Improvement > Components: jdbc > Affects Versions: 2.0.0 > Reporter: dieter von holten > Assignee: Michael Dick > Priority: Minor > Fix For: 2.0.0 > > Attachments: DvH090604a.diff, DvH090711Jira1118b.diff, OPENJPA-1118.diff.txt > > > the current code of OpenJPA can be enhanced by: > 1.) replacing Numbers.valueOf( int ) and Numbers.valueOf( long ) by their conunterparts in Integer and Long, as well as replacing new Integer/Byte/Short/Long/Character by their factory-methods > 2.) replace StringBuffer by StringBuilder, replace .append( "x" ) by .append( 'x' ) where possible > 3.) use more generics ( in Iterators, for example) > attached is a patch which contains 1.) for the below openjpa-jdbc/.. -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online.