openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pinaki Poddar (JIRA)" <j...@apache.org>
Subject [jira] Commented: (OPENJPA-1591) Refactor various parts to allow for greater extensibility
Date Tue, 23 Mar 2010 13:43:27 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-1591?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12848704#action_12848704
] 

Pinaki Poddar commented on OPENJPA-1591:
----------------------------------------

StateManagerImpl setPc()

1. This change needs more explanation of its rationale. A strict bi-directional relation exists
between StateManager and PersistenceCapable which is good for overall health of the software.
This method seems to weaken that contract. 

2. At present, nothing calls it. It is better to add new methods "for extensibility" as and
when they are needed.

3. The method should be renamed setPersistenceCapable(), if it has to exist.

4. Consider rolling back this change, for now.

 

> Refactor various parts to allow for greater extensibility
> ---------------------------------------------------------
>
>                 Key: OPENJPA-1591
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1591
>             Project: OpenJPA
>          Issue Type: Improvement
>          Components: kernel
>            Reporter: Rick Curtis
>            Assignee: Rick Curtis
>             Fix For: 2.0.0
>
>
> With this JIRA I will be refactoring a couple parts to allow for greater extensibility.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message