openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: how does openJPA determine project version 1.0/2.0
Date Thu, 11 Mar 2010 20:44:07 GMT
What version of Eclipse and have you added the JPA facet to your project
(which only supports JPA 1.0 until the Helios release that adds Java EE
6 support.)

Did you recompile your app against 2.0.0-beta2 and the Eclipse build
path and maven pom are pulling in 2.0.0-beta2?


-Donald


On 3/11/10 3:33 PM, Pmoran wrote:
> 
> I have a project that was 1.2.2 that I am migrating to 2.0. I keep getting an
> error that my project is version 1.0. So far this is what I have done
> Set openjpa.specification=jpa 2.0
> persistence.xml is version 2.0
> no orm.xml
> only openJPA-2.0.0beta2.jar on path
> Eclipse (STS version) IDE, maven pom based build
> 
> What am i missing?
> 
> Thanks for your help
> 
> Phill

Mime
View raw message