openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick (JIRA)" <j...@apache.org>
Subject [jira] Updated: (OPENJPA-1480) time zone info lost when using timestamp field
Date Fri, 12 Mar 2010 02:57:27 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-1480?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Dick updated OPENJPA-1480:
----------------------------------

    Fix Version/s:     (was: 1.2.3)
                       (was: 2.0.0)
                   2.0.1

> time zone info lost when using timestamp field
> ----------------------------------------------
>
>                 Key: OPENJPA-1480
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1480
>             Project: OpenJPA
>          Issue Type: Bug
>          Components: jdbc
>    Affects Versions: 1.2.3, 1.3.0, 2.0.0-M3, 2.0.0-beta
>         Environment: at least DB2, Derby, Sybase
>            Reporter: B.J. Reed
>            Assignee: Michael Dick
>            Priority: Minor
>             Fix For: 1.3.0, 2.0.1
>
>         Attachments: 1280-1.2.x.patch, OPENJPA-1480-TestCalendarField.patch, TestTimeZone.java,
TZDataModel.java
>
>
> Looks like OpenJPA always gets the time stamp out at the time zone of the machine, not
the time zone that was used originally.
> The test case is putting in 2 TimeStamps
>     TTimestamp = 4-3-2004 21:0:0.0 (America/New_York)
>     TTimestampUTC = 4-4-2004 2:0:0.0 (UTC)
> When OpenJPA gets those 2 timesamps back out of the database, they are 
>     TTimestamp = 4-3-2004 21:0:0.0 (America/New_York)
>     TTimestampUTC = 4-3-2004 21:0:0.0 (America/New_York)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message