openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick (JIRA)" <>
Subject [jira] Updated: (OPENJPA-1118) code changes towards broader use of JDK5 features
Date Mon, 08 Mar 2010 16:25:27 GMT


Michael Dick updated OPENJPA-1118:

    Attachment: OPENJPA-1118.diff.txt

Many of the changes have already been done under separate issues. The major outstanding part
is to replace Numbers.valueOf() with JRE factory methods. 

Autoboxing uses Integer.valueOf() automatically and since it makes the code easier to read
(subjective) and it's significantly easier to make the changes I've gone that route. 

Attaching a patch with the proposed changes. 

> code changes towards broader use of JDK5 features
> -------------------------------------------------
>                 Key: OPENJPA-1118
>                 URL:
>             Project: OpenJPA
>          Issue Type: Improvement
>          Components: jdbc
>    Affects Versions: 2.0.0
>            Reporter: dieter von holten
>            Assignee: Michael Dick
>            Priority: Minor
>             Fix For: 2.0.0
>         Attachments: DvH090604a.diff, DvH090711Jira1118b.diff, OPENJPA-1118.diff.txt
> the current code of OpenJPA can be enhanced by:
> 1.) replacing Numbers.valueOf( int ) and Numbers.valueOf( long ) by their conunterparts
in Integer and Long, as well as replacing new Integer/Byte/Short/Long/Character by their factory-methods
> 2.) replace StringBuffer by StringBuilder, replace .append( "x" ) by .append( 'x' ) where
> 3.) use more generics ( in Iterators, for example)
> attached is a patch which contains 1.) for the below openjpa-jdbc/..

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message