openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <stephen.alan.conno...@gmail.com>
Subject Re: OpenJPA trunk (2.0.0-SNAPSHOT) now requires Java SE 6
Date Wed, 24 Feb 2010 22:48:44 GMT
Have you considered using toolchains to help dancing within the different
jdk versions

On 24 February 2010 22:40, Donald Woods <dwoods@apache.org> wrote:

> We've backtracked some on OPENJPA-1520 and no longer require Java SE 6
> or later to use OpenJPA, but instead only require using Java SE 6 to
> build the artifacts which are still targeted to a 1.5 source/runtime
> level (even though some of the annotation support requires Java SE 6.)
>
> The junits can be built and run using Java SE 5, by using the new
> -Ptest-java5 profile which we are using during the nightly builds to
> verify that the Java SE 6 built artifacts still pass all junits when
> using Derby and either the Sun or IBM 1.5 JVMs.
>
> The above changes will be in the openjpa-2.0.0-beta2, which will go up
> for a release vote later today.
>
>
> -Donald
>
>
> On 2/18/10 10:55 PM, Donald Woods wrote:
> > As part of OPENJPA-1520, we are upgrading our trunk builds to require
> > Java SE 6 to compile and for runtime.  If there is a critical need to
> > maintain Java SE 5 support for our JPA 2.0 runtime, please speak-up now!
> >
> >
> > Thanks,
> > Donald
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message