openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Bauer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (OPENJPA-1248) LOB streaming does not work as expected
Date Tue, 10 Nov 2009 18:11:27 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-1248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12775971#action_12775971
] 

Jeremy Bauer commented on OPENJPA-1248:
---------------------------------------

I committed a partial fix for Oracle under revision 834564. With the exception of adding the
ConnectionRetainMode setting to the test config, the tests pass as-is (ie. expected behavior
is unchanged). I also doc'd the ConnectionRetainMode requirement in the Oracle section of
the manual.

One potential issue may still remain. If a LOB column contains a null (ex. inserted by an
external application) and OpenJPA tries to update that value a failure may still result. The
cumbersome patch I submitted for OpenJPA-1249 will handle that case, but I have a more direct
approach in mind that uses SQL instead of native APIs.

> LOB streaming does not work as expected
> ---------------------------------------
>
>                 Key: OPENJPA-1248
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1248
>             Project: OpenJPA
>          Issue Type: Bug
>          Components: jdbc
>    Affects Versions: 1.1.0, 1.2.0, 1.2.1, 1.3.0, 2.0.0
>         Environment: Oracle, MySQL, PostgreSQL, SQL Server
>            Reporter: Milosz Tylenda
>         Attachments: failures.txt, TestReaderLob_oracle.log
>
>
> TestReaderLob does not pass with any of the databases indicated in the test case: Oracle,
MySQL, PostgreSQL, SQL Server. TestInputStreamLob passes only with MySQL and PostgreSQL.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message