openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Beer (JIRA)" <j...@apache.org>
Subject [jira] Updated: (OPENJPA-483) config for openjpa.jdbc.Schemas not applied to SQL (HSQL)
Date Wed, 28 Oct 2009 18:43:59 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-483?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Beer updated OPENJPA-483:
-------------------------------

    Attachment: HSQLDB-openjpa Test.zip

test project showing schema bug with openjpa 1.2.1 and HSQLDB.

just run ant test. This will attempt to create a db and connect to it. Then connect to the
nely created testdb via the HSQL database manager.

> config for openjpa.jdbc.Schemas not applied to SQL (HSQL)
> ---------------------------------------------------------
>
>                 Key: OPENJPA-483
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-483
>             Project: OpenJPA
>          Issue Type: Bug
>    Affects Versions: 1.1.0
>         Environment: Java JDK 1.5.0_12, Linux, Hypersonic DB
>            Reporter: Adam Hardy
>         Attachments: HSQLDB-openjpa Test.zip, schemabug.zip, schemabug2.zip
>
>
> OpenJPA should be able to see and access schemas but doesn't. 
> I configured this with openjpa.jdbc.Schema=DEV (my schema name) 
> I also tried putting the schema name everywhere possible in the metadata, i.e. in the
<schema>DEV</schema> tags and in table tags, and in:
>   <persistence-unit-metadata>
>     <xml-mapping-metadata-complete />
>     <persistence-unit-defaults>
>       <schema>DEV</schema>
>     </persistence-unit-defaults>
>   </persistence-unit-metadata>
> I will include a zipped up test project illustrating the problem. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message