openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Curtis (JIRA)" <j...@apache.org>
Subject [jira] Created: (OPENJPA-1302) Ehcache product derivation isn't detected when running in WebSphere
Date Tue, 15 Sep 2009 18:48:57 GMT
Ehcache product derivation isn't detected when running in WebSphere
-------------------------------------------------------------------

                 Key: OPENJPA-1302
                 URL: https://issues.apache.org/jira/browse/OPENJPA-1302
             Project: OpenJPA
          Issue Type: Bug
          Components: lib
         Environment: Win XP, WAS V7.0.0.5
            Reporter: Rick Curtis
            Assignee: Rick Curtis
             Fix For: 2.0.0


I tried to configure Ehcache using the instructions documented on their website [1] and found
that using the 'ehcache' alias (for openjpa.QueryCache and openjpa.DataCacheManager) does
not work in WAS. It does work when running in a JSE environment.

After digging around for awhile I found that when I added ehcache as an application shared
library, those classes were not available to the static initializer in org.apache.openjpa.lib.conf.ProductDerivations.
Since the ehcache product derivation wasn't found, the 'ehcache' alias wasn't registered.

[1] http://ehcache.org/documentation/openjpa_provider.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message