openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dick <michael.d.d...@gmail.com>
Subject Re: Hang-ups with -javaagent
Date Mon, 22 Jun 2009 20:00:40 GMT
Random thought Milosz, are you using the jar from your workspace or one from
outside the dev tree (say .m2/repositorys/org/apache/openjpa/) ?

If it's in your workspace I could see classloaders getting confused. Kind of
a shot in the dark, but maybe it'll help.

-mike

On Mon, Jun 22, 2009 at 2:51 PM, Rick Curtis <curtisr7@gmail.com> wrote:

>
> Milosz-
> I tried all the java implementations that you mention in your previous post
> and I'm unable to recreate the hang that you're seeing... hopefully someone
> else will have better luck recreating the problem.
>
> Note: All of the testing I did was on MySQL with both the 3.1.14 and 5.0.0
> drivers.
>
> -Rick
>
>
> MiƂosz Tylenda wrote:
> >
> > Rick,
> >
> > For me it's easy but it looks like only me has that problem. I just run
> > from Eclipse the TestBasicAnnotation test in debug mode. I run it with
> > MySQL or PostgreSQL. I specify all database properties thru JVM "-D"
> > arguments. I also include -javaagent. I have the entire OpenJPA source as
> > one Eclipse project. Usually it hangs. Let me know if any specific
> details
> > you need.
> >
> > Cheers,
> > Milosz
> >
> >
> >>
> >> Milosz -
> >> Is there an easy way to reproduce this problem. If so, please post it
> and
> >> I'll take a look.
> >>
> >> -Rick
> >>
> >> --
> >> View this message in context:
> >> http://n2.nabble.com/Hang-ups-with--javaagent-tp3072225p3136727.html
> >> Sent from the OpenJPA Developers mailing list archive at Nabble.com.
> >>
> >>
> >
> >
>
> --
> View this message in context:
> http://n2.nabble.com/Hang-ups-with--javaagent-tp3072225p3138329.html
> Sent from the OpenJPA Developers mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message