openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Bauer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (OPENJPA-1033) Update supported database and driver matrix
Date Thu, 16 Apr 2009 19:50:14 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-1033?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12699825#action_12699825
] 

Jeremy Bauer commented on OPENJPA-1033:
---------------------------------------

I reviewed the patch and I have some questions/concerns before I commit the changes.

- The patch updates the database version levels for several databases.  Some versions, DB2
8.1 for example, may work fine with OpenJPA.  Should that version be removed for the sake
of currency?  Would it be better to list a minimum level of support each database with the
assumption (or explicit verbage) that newer versions claiming backward compatibility are also
supported?

- Has OpenJPA been fully tested with each of the versions specified?  Does anyone know (or
have an opinion of) what it means to be a supported version?  Does it carry test implications
or is it more a statement of what OpenJPA will be more apt to support if problems are found?

I'm all for staying current, I just wanted to get these things out in the open and give time
for others to comment before committing the patch.

Regardless of the version updates, I think the other updates are good and the links to the
support db sections is a nice feature.

> Update supported database and driver matrix
> -------------------------------------------
>
>                 Key: OPENJPA-1033
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1033
>             Project: OpenJPA
>          Issue Type: Sub-task
>          Components: docs
>    Affects Versions: 2.0.0
>            Reporter: Donald Woods
>            Assignee: Donald Woods
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: OPENJPA-1033.patch
>
>
> The list of supported databases is getting old.  Need to update the supported/tested
levels for Derby, DB2, Informix, MS SQL and Oracle.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message