openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Milosz Tylenda (JIRA)" <j...@apache.org>
Subject [jira] Commented: (OPENJPA-1033) Update supported database and driver matrix
Date Fri, 17 Apr 2009 19:50:14 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-1033?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12700302#action_12700302
] 

Milosz Tylenda commented on OPENJPA-1033:
-----------------------------------------

Donald & Jeremy, good idea to address this. My opinion:

- I would list a minimum level of support for each database with the explicit verbage that
newer versions claiming backward compatibility are also supported (or just: verbage that newer
versions are also supported). This should be clear for users and will save us some work as
databases are updated quite frequently.

- I would define a supported version/database as a statement of what OpenJPA will be more
apt to support if problems are found. I assume we are not able to run tests regularly on every
minor (or even major) database version. Also, I believe Derby being the only one which passes
every (nearly) test case.

- I would bump up the minimum PostgreSQL version to 7.4 as previous versions seem not to be
updated by PostgreSQL programmers for a long time.

- I believe the previous version of the patch was correcting the order of sections. It might
have been another good idea but probaly now needs a new patch because of the recent updates
for Firebird.


> Update supported database and driver matrix
> -------------------------------------------
>
>                 Key: OPENJPA-1033
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1033
>             Project: OpenJPA
>          Issue Type: Sub-task
>          Components: docs
>    Affects Versions: 2.0.0
>            Reporter: Donald Woods
>            Assignee: Donald Woods
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: OPENJPA-1033-db_versions.patch, OPENJPA-1033-links_and_mssql.patch
>
>
> The list of supported databases is getting old.  Need to update the supported/tested
levels for Derby, DB2, Informix, MS SQL and Oracle.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message