openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Albert Lee <allee8...@gmail.com>
Subject Re: [DISCUSS] Drop build support for Java 5?
Date Fri, 27 Mar 2009 17:04:37 GMT
Are there any products relying on using the trunk for building personalities
other than JPA 2.0? If we plan to "encourage" those usages, we should at
least keep the requirements to compile/run the base modules (e.g. kernel,
lib, util etc.) at the 1.5 level. Whereas the jdbc, persistence and
persistence-jdbc modules can be compile and run with 1.6 JDK. This implies
OpenJPA JPA 2.0 personality will require 1.6 JDK for execution.

If we cut the cord completely, we may loss developers who are able to
contribute at the base modules that benefit both parties.

Albert Lee.

On Fri, Mar 27, 2009 at 9:56 AM, Donald Woods <dwoods@apache.org> wrote:

> Why do we need to support Java 5 users with OpenJPA 2.0?
> If someone wants to continue using Java 5 after it's end-of-service date
> this year, then they can continue using one of the 1.0.x/1.1.x/1.2.x/1.3.x
> branches....
>
> Don't see why we need to bend over backwards for Java 5, consider the JPA2
> Spec is part of the JEE6 Spec, which requires Java 6 or later.
>
>
> -Donald
>
>
>
> Kevin Sutter wrote:
>
>> Are there any concerns with building with Java 6 and running in a Java 5
>> environment?  Will this just "work" out of the box?  Or, do we need to
>> build
>> with the -target option to be compatible with Java 5?  Or, do we need to
>> produce both versions?  We still need to support the Java 5 runtime
>> environment, even if we build with Java 6.
>>
>> Kevin
>>
>> On Thu, Mar 26, 2009 at 2:17 PM, Jeremy Bauer <techhusky@gmail.com>
>> wrote:
>>
>>  +1 for pulling the plug on Java 5 in trunk.  We are on a major release
>>> boundary with 2.0, so now would be the time to do it.
>>>
>>> Moving to Java 6: (good)
>>> - Meets JPA 2.0 JSE 6 annotation processing requirement
>>> - Fewer Java versions to support (and less confusion regarding build vs.
>>> runtime Java version requirements)
>>> - The ability to naturally (no version checks, reflection, etc.) use new
>>> Java 6 features such as JDBC 4
>>>
>>> Continue providing compile support for Java 5: (bad)
>>> - Additional requirement of making sure OpenJPA builds on both versions
>>> of
>>> Java
>>> - Inability to easily use new Java 6 features without version checks and
>>> such
>>> - Multiple code paths to maintain for version specific code
>>>
>>> I agree that if we pull the plug on Java 5, there should be some sort of
>>> announce & time period that gives folks ample time to prepare.  One or
>>> two
>>> months seems reasonable.
>>>
>>> -Jeremy
>>>
>>> On Thu, Mar 26, 2009 at 10:01 AM, Kevin Sutter <kwsutter@gmail.com>
>>> wrote:
>>>
>>>  Per the discussion with OPENJPA-5 [1], the question of continuing
>>>> support
>>>> of
>>>> building with Java 5 has been brought up.  Due to the annotation
>>>>
>>> processing
>>>
>>>> that will be required for JPA 2.0, the use of Java 6 will become a
>>>> requirement for trunk.  But, do we have to continue to support building
>>>> with
>>>> Java 5.  Pinaki has recently committed changes to allow building with
>>>> either
>>>> Java 5 or Java 6, but these changes will affect our code path as it
>>>>
>>> relates
>>>
>>>> to connection processing.  So, should we bite the bullet and pull the
>>>>
>>> plug
>>>
>>>> on Java 5 from a build perspective?  This would be for trunk (JPA 2.0)
>>>>
>>> only
>>>
>>>> and beyond.
>>>>
>>>> Comments, suggestions, complaints are all welcome.
>>>>
>>>> Thanks,
>>>> Kevin
>>>>
>>>> [1] https://issues.apache.org/jira/browse/OPENJPA-5
>>>>
>>>>
>>


-- 
Albert Lee.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message