openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Albert Lee (JIRA)" <>
Subject [jira] Commented: (OPENJPA-866) DBDictionary.maxTableNameLength is not checked when using SynchronizeMappings
Date Wed, 11 Mar 2009 14:04:50 GMT


Albert Lee commented on OPENJPA-866:

I tried apply the patch against the trunk but mvn clean install consistently failied in:

Results :

Tests in error:

Tests run: 1374, Failures: 0, Errors: 1, Skipped: 0

I ran the with and without the patch twice and still failed the same say.

Can you take a look and see what may be causing the problem ?

Albert Lee.

> DBDictionary.maxTableNameLength is not checked when using SynchronizeMappings
> -----------------------------------------------------------------------------
>                 Key: OPENJPA-866
>                 URL:
>             Project: OpenJPA
>          Issue Type: Bug
>    Affects Versions: 1.2.0
>            Reporter: Alan Raison
>            Assignee: Tim McConnell
>         Attachments: OPENJPA-866_3.patch
> Per Alan Raison's post to the dev mailing list there appears to be a problem with trimming
table names when SynchronizeMappings is used. 
> Here's the email that started the conversation : 
> I have been writing a DBDictionary for the Ingres database and have been running the
test cases.  Ingres supports 32 character table names, and this has been set in the dictionary.
 However some tests have hit an error whereby the table name is too long for the database.
> I notice in the DBDictionary class there is a method called "getValidTableName" but this
clearly isn't being used since it is trying to use a table name which is too long.  Other
databases (such as Oracle) also have quite a short maximum length for table names, so this
problem must be able to overcome, but I can't see anything in other Dictionary classes.
> Is there anything special I should be doing to run the tests?  I am currently running
through mvn test.
> My draft DBDictionary class is attached along with a sample surefire report (with my
username and password removed!)
> The full thread can be seen here :

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message