openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "johan jarkovic (JIRA)" <j...@apache.org>
Subject [jira] Created: (OPENJPA-836) after em.clear the next select query on the table (in a new transaction) returns empty Entity.
Date Fri, 19 Dec 2008 12:05:44 GMT
after em.clear the next select query on the table (in a new transaction) returns empty Entity.
----------------------------------------------------------------------------------------------

                 Key: OPENJPA-836
                 URL: https://issues.apache.org/jira/browse/OPENJPA-836
             Project: OpenJPA
          Issue Type: Bug
          Components: datacache
    Affects Versions: 1.2.0
         Environment: Weblogic 10.3 on WinXP EJB 3.0 (CMT)
<property name="kodo.DataCache" value="true"/>
      <property name="kodo.RemoteCommitProvider" value="sjvm"/>
            Reporter: johan jarkovic


I have the cache enabled. kodo.DataCache=true
After a em.clear I do a select query on the table that I persisted. This is done on a  new
transaction (new webpage request). 
I get back the Entity but only it's id has been set. everything else is null. 
>From then on all the attempts to execute the same query get the same result.

This does not happen if kodo.DataCache=false.

Note:  The original weblogic 10.3 openjpa jar which is version 1.1 has been replaced with
version 1.2.0. 

The query that is executed is: "select cats from Catalogues cats where cats.catalogueId=203"

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message