openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fernando (JIRA)" <j...@apache.org>
Subject [jira] Created: (OPENJPA-820) slices: a simple query is failing (unique, but totally sending wrong parameters to SQL)
Date Tue, 09 Dec 2008 23:02:44 GMT
slices: a simple query is failing (unique, but totally sending wrong parameters to SQL)
---------------------------------------------------------------------------------------

                 Key: OPENJPA-820
                 URL: https://issues.apache.org/jira/browse/OPENJPA-820
             Project: OpenJPA
          Issue Type: Bug
          Components: kernel
    Affects Versions: 2.0.0
            Reporter: Fernando
            Priority: Critical


Thank you for fixing that PCPath issue!  Now I can move on to find the next bug to fix. :)
 And I didn't have to wait long:

I am trying to run the simple query below, against 2 slices.

select this from com.protrade.fandom.data.entities.TeamFanJersey this  where this.teamFan
= :p0


These are the two queries run on the low level databases:

SELECT t0.JDOID, t0.JERSEYLEVEL, t0.TEAMFAN_JDOID FROM TEAMFANJERSEY t0 WHERE (t0.TEAMFAN_JDOID
IS NULL)

SELECT t0.JDOID, t0.JERSEYLEVEL, t0.TEAMFAN_JDOID FROM TEAMFANJERSEY t0 WHERE (t0.TEAMFAN_JDOID
= 8574250)


As you can see, the query run against Slice1 thinks the parameter is Null, while the query
run against Slice2, knows the proper value of the parameter.  This SQL is the lowlevel sql
sent through the Mysql Driver (mysql driver logging).

I guess it's another bug in the DistributedPreparedStatement not properly setting parameters
to all sub statements.. just a guess.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message