openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fernando Padilla <f...@alum.mit.edu>
Subject Re: [jira] Commented: (OPENJPA-820) slices: a simple query is failing (unique, but totally sending wrong parameters to SQL)
Date Thu, 11 Dec 2008 01:55:16 GMT
cool.. but what I was getting at..

Do you have any ideas what the test case could be?  It is an 
intermittent error.. would you have any clues as to what could force 
this to happen, to make it consistently reproduceable?

I am assuming that you already have a test for a simple query, what else 
can I test for?  Have it execute the query 30 times until it fails?

But I'll review your unit test I suppose.. maybe there is a slight 
nuance there..

but again, does your gut have any tips?



Pinaki Poddar wrote:
>> So, now that I have your attention, let's start to discuss.. what do you
> think it could be?
> 
>    Please post a reproducible JUnit test case without the scaffolding. It
> will help us to pinpoint the issue.
> 
>> how come your unit tests didn't catch the other bugs that I filed? 
> 
> I am working towards that day when my unit tests will find all the bugs ;) 
> Also that is why your hard work is much more appreciated. 
> You can see for yourself the existing test cases for Slice in svn repository
> and you are welcome to contribute new ones. But I agree that test coverage
> needs improvement -- and contributions are very welcome.
> 
> 
> 

Mime
View raw message