openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fernando (JIRA)" <j...@apache.org>
Subject [jira] Created: (OPENJPA-781) openjpa-jdbc depends on postgres driver, should be "provided"
Date Mon, 24 Nov 2008 23:49:44 GMT
openjpa-jdbc depends on postgres driver, should be "provided"
-------------------------------------------------------------

                 Key: OPENJPA-781
                 URL: https://issues.apache.org/jira/browse/OPENJPA-781
             Project: OpenJPA
          Issue Type: Improvement
          Components: build / infrastructure
    Affects Versions: 2.0.0
            Reporter: Fernando


just need to add <scope>provided</scope> to the postgres sql dependency.


Index: openjpa-jdbc/pom.xml
===================================================================
--- openjpa-jdbc/pom.xml        (revision 720348)
+++ openjpa-jdbc/pom.xml        (working copy)
@@ -47,12 +47,13 @@
         <dependency>
             <groupId>hsqldb</groupId>
             <artifactId>hsqldb</artifactId>
-            <scope>compile</scope>
+            <scope>provided</scope>
         </dependency>
         <dependency>
             <groupId>postgresql</groupId>
             <artifactId>postgresql</artifactId>
             <version>8.1-407.jdbc3</version>
+            <scope>provided</scope>
         </dependency>
     </dependencies>
     <build>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message