openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ognjen Blagojevic <ogn...@etf.bg.ac.yu>
Subject Building OpenJPA
Date Mon, 01 Sep 2008 12:48:16 GMT
Hi devs,

I have a two suggestions for Building OpenJPA page [1]:

1. Recommended version for Maven is 2.0.4, but trying to build with that 
one, results an error:

[INFO] [jar:jar]
[INFO] Building jar: 
D:\java-ext\openjpa\openjpa-lib\target\openjpa-lib-1.3.0-SNAPSHOT.jar
[INFO]----------------------------------------------------------------------------
[INFO] Building OpenJPA Kernel
[INFO]    task-segment: [package]
[INFO]----------------------------------------------------------------------------
[INFO]------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]------------------------------------------------------------------------
[INFO] Error resolving version for 
'org.apache.maven.plugins:maven-jar-plugin':
Plugin requires Maven version 2.0.6
[INFO]------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]------------------------------------------------------------------------
[INFO] Total time: 4 seconds
[INFO] Finished at: Mon Sep 01 14:42:14 CEST 2008
[INFO] Final Memory: 11M/20M
[INFO]-----------------------------------------------------------------------

Maybe the recommended version should be 2.0.9 or 2.0.6?


2. When tests fail, it is still impossible to build just with parameter 
"-Dtest=false", but also with "-DfailIfNoTests=false". This should be 
documented.


Regards,
Ognjen

[1] http://openjpa.apache.org/building-openjpa.html

Mime
View raw message