openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pinaki Poddar (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (OPENJPA-434) Setting a null value for a primitive type field in a query results in hang
Date Sat, 02 Aug 2008 14:27:44 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-434?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pinaki Poddar reopened OPENJPA-434:
-----------------------------------


> Setting a null value for a primitive type field in a query results in hang
> --------------------------------------------------------------------------
>
>                 Key: OPENJPA-434
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-434
>             Project: OpenJPA
>          Issue Type: Bug
>    Affects Versions: 1.0.0
>            Reporter: Nick Johnson
>            Assignee: Pinaki Poddar
>            Priority: Minor
>             Fix For: 1.3.0
>
>
> I'm still working on a testcase to demonstrate this, but the basic steps are roughly
like this:
> 1. Create a Query with a parameter for a primitive type field (e.g., long fooId)
> 2. Pass in a null for that parameter.
> 3. Execute the query.  OpenJPA correctly complains that a null has been passed for a
primitive type field...
> but once the EntityManager closes, it seems to hang forever.
> If I can get a TestCase together that demonstrates this problem, I'll attach it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message