openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick" <mik...@apache.org>
Subject Re: maven repository - 1.1.0 is broken
Date Fri, 06 Jun 2008 19:57:56 GMT
Hi all,

I believe we're mostly back in business. Yesterday I repopulated most of the
maven repository on people.apache.org. It synced up with ibiblio overnight
and this morning I ran a simple sanity test :

I wiped out my local repository and build a project with this as a
dependency :
        <dependency>
            <groupId>org.apache.openjpa</groupId>
            <artifactId>openjpa</artifactId>
            <version>1.1.0</version>
        </dependency>

The relevant section of the maven output follows :
[INFO] Using default encoding to copy filtered resources.
Downloading:
http://repo1.maven.org/maven2/org/apache/openjpa/openjpa/1.1.0/openjpa-1.1.0.pom
7K downloaded
Downloading:
http://repo1.maven.org/maven2/org/apache/openjpa/openjpa-parent/1.1.0/openjpa-parent-1.1.0.pom
18K downloaded
Downloading:
http://repo1.maven.org/maven2/org/apache/openjpa/openjpa/1.1.0/openjpa-1.1.0.jar
5135K downloaded
[INFO] [compiler:compile]
[INFO] Compiling 22 source files to
/home/mikedd/workspaces/jpa/tests/target/classes
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL

There's still some cleanup that needs to be done, but for now I believe the
maven repositories are functional.

-Mike


On Wed, Jun 4, 2008 at 5:56 PM, Michael Dick <michael.d.dick@gmail.com>
wrote:

> At the moment I'm a bit dead in the water. The maven stage plugin appears
> to be hanging here :
> [INFO] Creating zip file.
> [INFO] Creating rename script.
> [INFO] Uploading zip file to the target repository.
> [INFO] Unpacking zip file on the target machine.
> [INFO] Deleting zip file from the target repository.
> [INFO] Running rename script on the target machine.
>
> Assuming it does come back from running the rename script I can go ahead an
> republish the rest of the artifacts.I'm not in the Apache Web of Trust
> (yet), hopefully that isn't a problem.
>
> Regards,
>
> -Mike
>
>
> On Wed, Jun 4, 2008 at 5:46 PM, Craig L Russell <Craig.Russell@sun.com>
> wrote:
>
>> Hi Mike,
>>
>> Can you also sign the artifacts that are missing valid signatures?
>>
>> Thanks,
>>
>> Craig
>>
>>
>> On Jun 4, 2008, at 3:27 PM, Michael Dick wrote:
>>
>>  Hi all,
>>>
>>> For the time being I've put the missing artifacts on people.apache.orgunder
>>> my home directory. You can access them by adding something like this to
>>> pom.xml :
>>>   <repositories>
>>>       <repository>
>>>           <id>mike's temporary repository</id>
>>>           <url>http://people.apache.org/~mikedd/temp-repo<http://people.apache.org/%7Emikedd/temp-repo>
>>> </url>
>>>       </repository>
>>>   </repositories>
>>>
>>> I'll do the same for the official mirrored repositories. They should sync
>>> up
>>> again overnight and we'll be back in business.
>>>
>>> -Mike
>>>
>>> On Wed, Jun 4, 2008 at 1:44 PM, Michael Dick <mikedd@apache.org> wrote:
>>>
>>>  Hi Stojce,
>>>>
>>>> It looks like only part of the artifacts were published to the maven
>>>> repository. Openjpa-parent, openjpa-examples were left out (might be
>>>> others
>>>> that I missed). I haven't looked in depth but I'm guessing something
>>>> went
>>>> wrong with the stage plugin when they were copied from our "voting"
>>>> repository to the production repository.
>>>>
>>>> I'll take a closer look. Hopefully all we have to do is run the stage
>>>> plugin again to republish.
>>>>
>>>> -mike
>>>>
>>>>
>>>> On Wed, Jun 4, 2008 at 3:07 AM, Stojce Dimski <sdmiski@yahoo.it> wrote:
>>>>
>>>>  As already pointed few days ago in
>>>>>
>>>>> http://mail-archives.apache.org/mod_mbox/openjpa-users/200805.mbox/%3c20080529170813.GA28046@sfu.ca%3e
>>>>> maven repository of 1.1.0 release is broken as there is wrong parent
>>>>> pom
>>>>> settings in all modules. Parent pom per default is searched in ../
>>>>> folder
>>>>> respect to a module declaring their parent so it should stay 'above'
>>>>> all
>>>>> modules or '<parent>' part should be fixed...
>>>>>
>>>>>
>>>>>    ___________________________________
>>>>> Scopri il Blog di Yahoo! Mail: trucchi, novità, consigli... e la tua
>>>>> opinione!
>>>>> http://www.ymailblogit.com/blog/
>>>>>
>>>>>
>>>>
>>>>
>> Craig Russell
>> Architect, Sun Java Enterprise System http://java.sun.com/products/jdo
>> 408 276-5638 mailto:Craig.Russell@sun.com
>> P.S. A good JDO? O, Gasp!
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message