openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick (JIRA)" <j...@apache.org>
Subject [jira] Updated: (OPENJPA-594) Incorrect schema separator used for Informix tables
Date Thu, 08 May 2008 18:57:21 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-594?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Dick updated OPENJPA-594:
---------------------------------

              Assignee: Michael Dick
    Remaining Estimate: 0h
     Original Estimate: 0h

Looks like this is true for Informix 9.3 as well (which is the oldest version supported by
OpenJPA). From the SQL guide (page 4-46) the syntax looks something like this : 

CREATE TABLE [database@[dbservername]]:[schemaname].tablename . . .
                                            

> Incorrect schema separator used for Informix tables
> ---------------------------------------------------
>
>                 Key: OPENJPA-594
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-594
>             Project: OpenJPA
>          Issue Type: Bug
>          Components: jdbc
>    Affects Versions: 1.0.2
>            Reporter: Dinkar Rao
>            Assignee: Michael Dick
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> With Informix IDS 9.4 (or 10.0), when a schema  is specified in the table annotation
or in the openjpa.jdbc.schema property, a SQL for CREATE TABLE with invalid syntax is generated:
> CREATE TABLE MYSCHEMA:MYTABLE (...);
> The correct separator between the schema and the table is "dot".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message