openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebastian Souza" <sebaso...@gmail.com>
Subject Problems
Date Sat, 02 Feb 2008 19:51:09 GMT
Please, this my last chance. I were writing to forums but nobody could help
me with my problem.

i couldnt ran the enhancer in my application and my performance is horrible.


i try to build my entities classes but the enhancer couldnt find them.

My scenario is:

I only use orm.xml and persistence.xml (i dont use attributes in my
classes).

I have a persistence project where the persistence.xml and orm.xml resides
Then i have my entities projects where  i put my entities

my build.xml in the entities project is

<?xml version="1.0" encoding="UTF-8"?>
<project name="build" default="enhance" basedir=".">
        <path id="build.classpath">
                <fileset dir="jar">
                        <include name="*.jar" />
                </fileset>
        </path>
        <target name="enhance">
                <java classname="org.apache.openjpa.enhance.PCEnhancer"
fork="true" failonerror="true">
                        <arg value="-p"/>
                        <classpath refid="build.classpath"/>
                        <arg
value="../Persistence/src/META-INF/persistence.xml"/>
                        <classpath>
                                <pathelement path="${java.class.path}"/>
                                        <pathelement
location="../Persistence/src/META-INF/"/>
                        </classpath>
                </java>
        </target>
</project>

the result:

     [java] 343  ITSM  INFO   [main] openjpa.Tool - No targets were given.
 Running on all classes in your persistent classes list, or all metadata
files in classpath directories if you have not listed your persistent
classes.  Use -help to display tool usage information.
     [java] 1421  ITSM  WARN   [main] openjpa.Tool - Found no class to
enhance.

i would appreciate any help you can give me
regards

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message