openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dain Sundstrom (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (OPENJPA-316) Unenhanced OneToMany collection not loaded
Date Thu, 17 Jan 2008 00:40:34 GMT

     [ https://issues.apache.org/jira/browse/OPENJPA-316?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dain Sundstrom reopened OPENJPA-316:
------------------------------------


I would expect that when in unenhanced mode, OpenJPA would eager load all fields and store
all changed fields like Hibernate does.  This isn't efficient, but that is fine for unenhanced
applications.  The alternative is strange behavior that can result in corrupt data (load data,
make calculation based on missing data, and store it == corruption).



> Unenhanced OneToMany collection not loaded
> ------------------------------------------
>
>                 Key: OPENJPA-316
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-316
>             Project: OpenJPA
>          Issue Type: Bug
>            Reporter: Dain Sundstrom
>             Fix For: 1.1.0
>
>         Attachments: OPENJPA-316.patch
>
>
> Unenhanced OneToMany fields are not loaded when using a new entity manager.  The fields
appear to work when reusing a resource local em across multiple transactions, but when a new
em is created the OneToMany field will be null.
> Attached is a test case that reproduces this problem.  The test method has been disabled
so the build will not break.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message