openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Sutter (JIRA)" <j...@apache.org>
Subject [jira] Issue Commented: (OPENJPA-429) Recent changes have caused problems building with IBM JDK
Date Tue, 13 Nov 2007 14:49:05 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-429?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12542155
] 

Kevin Sutter commented on OPENJPA-429:
--------------------------------------

I've narrowed the problem down to the @ReadOnly annotation processing.  Although we have had
this annotation for quite some time in OpenJPA, some recent test additions just surfaced this
problem.  Entity class org.apache.openjpa.persistence.jdbc.annotations.ExtensionsEntity uses
the @ReadOnly annotation.  For some reason, the IBM JDK is having problems loading the UpdateAction
class necessary for the "value" parameter.  I've tried experimenting with this annotation
definition and usage to see if I could workaround the problem, but nothing yet.  I will follow
up with the IBM JDK team to see how we can get this resolved.

I am currently running with SR5 of the IBM JDK:

java full version "J2RE 1.5.0 IBM Windows 32 build pwi32dev-20070511 (SR5)"

According to the posts that Mike made on the dev mailing list, he also tried with a newer
version of the JDK.  I will need to verify that before I can post a problem report to the
IBM JDK anyway.

Kevin

> Recent changes have caused problems building with IBM JDK
> ---------------------------------------------------------
>
> common.concepts.key: OPENJPA-429
> common.concepts.url: https://issues.apache.org/jira/browse/OPENJPA-429
>common.concepts.project: OpenJPA
>common.concepts.issuetype: Bug
>common.concepts.components: build / infrastructure
>    Affects Versions: 1.1.0
>issue.field.reporter: Kevin Sutter
>
> This started on the dev mailing list:  http://www.nabble.com/build-error-with-trunk-tf4733970.html
> Trunk (1.1.0) is not building with the IBM JDK.  It is building okay with the Sun JDK.
 It's not always consistent, but an example call stack is as follows:
> 2000  test  WARN   [main] openjpa.Enhance - Type "class org.apache.openjpa.enhance.TestEnhancementConfiguration"
has no metadata; enhancing as persistence aware. If you intended for "class org.apache.openjpa.enhance.TestEnhancementConfiguration"
to be persistence-capable, then this means that OpenJPA could not find any metadata for "class
org.apache.openjpa.enhance.TestEnhancementConfiguration".
> This can happen if the directory containing your metadata is not in your CLASSPATH, or
if your metadata files are not named properly. See the documentation on metadata placement
for more information.
> java.lang.ClassFormatError
>         at java.lang.ClassLoader.defineClassImpl(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:228)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:163)
>         at org.apache.openjpa.lib.util.TemporaryClassLoader.loadClass(TemporaryClassLoader.java:78)
>         at org.apache.openjpa.lib.util.TemporaryClassLoader.loadClass(TemporaryClassLoader.java:44)
>         at com.ibm.oti.reflect.AnnotationHelper.getReturnValueFromEntry(NativeMethod)
>         at com.ibm.oti.reflect.AnnotationHelper.access$000(AnnotationHelper.java:14)
>         at com.ibm.oti.reflect.AnnotationHelper$AnnotationInvocationHandler.invoke(AnnotationHelper.java:104)
>         at $Proxy27.value(Unknown Source)
>         at org.apache.openjpa.persistence.AnnotationPersistenceMetaDataParser.parseReadOnly(AnnotationPersistenceMetaDataParser.java:1145)
>         at org.apache.openjpa.persistence.AnnotationPersistenceMetaDataParser.parseMemberAnnotations(AnnotationPersistenceMetaDataParser.java:1105)
>         at org.apache.openjpa.persistence.AnnotationPersistenceMetaDataParser.parseClassAnnotations(AnnotationPersistenceMetaDataParser.java:606)
>         at org.apache.openjpa.persistence.AnnotationPersistenceMetaDataParser.parse(AnnotationPersistenceMetaDataParser.java:351)
>         at org.apache.openjpa.persistence.PersistenceMetaDataFactory.load(PersistenceMetaDataFactory.java:229)
>         at org.apache.openjpa.meta.MetaDataRepository.getMetaDataInternal(MetaDataRepository.java:470)
>         at org.apache.openjpa.meta.MetaDataRepository.getMetaData(MetaDataRepository.java:290)
>         at org.apache.openjpa.enhance.PCEnhancer.<init>(PCEnhancer.java:240)
>         at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:4344)
>         at org.apache.openjpa.ant.PCEnhancerTask.executeOn(PCEnhancerTask.java:89)
>         at org.apache.openjpa.lib.ant.AbstractTask.execute(AbstractTask.java:172)
>         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
>         at org.apache.tools.ant.Task.perform(Task.java:364)
>         at org.apache.tools.ant.Target.execute(Target.java:341)
>         at org.apache.maven.plugin.antrun.AbstractAntMojo.executeTasks(AbstractAntMojo.java:108)
>         at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:83)
>         at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:443)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:480)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:459)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:334)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:272)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:615)
>         at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>         at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error executing ant tasks
> Embedded error: java.lang.ClassFormatError

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message