openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rgarret <RGAR...@co.pierce.wa.us>
Subject Re: Lazy loading not working.
Date Thu, 04 Oct 2007 19:27:54 GMT

Thanks for all the help, everything is going smoothly now. Like I said, the
latest snapshot took care of the OneToOne relationship and it makes sense
that enums are just basic.

Thanks again!
Reece


Kevin Sutter wrote:
> 
> On 10/4/07, Patrick Linskey <plinskey@gmail.com> wrote:
>>
>>
>> I believe that you can leave out the @Basic annotation for enums if
>> you'd prefer, as well.
> 
> 
> That is correct.  @Basic is optional for enums.
> 
> Kevin
> 
> -Patrick
>>
>> On 10/4/07, rgarret <RGARRET@co.pierce.wa.us> wrote:
>> >
>> > Alex,
>> >
>> > I am enhancing all of my model classes at build time. I found a fixed
>> bug
>> > that pertains to my issue:
>> http://issues.apache.org/jira/browse/OPENJPA-347.
>> > After upgrading to the latest snapshot my OneToOne relationship behaved
>> > properly but the ManyToOne still eagerly fetched. I changed from
>> ManyToOne
>> > to Basic and now everything is working well.
>> >
>> > I'm not sure if declaring the relationship as basic is the right thing
>> to do
>> > as it really is ManyToOne. I have verified that retrieval works
>> properly
>> but
>> > have yet to test persisting.
>> >
>> > Thanks for your help,
>> > Reece
>> >
>> >
>> > AlexD. wrote:
>> > >
>> > > Hallo,
>> > >
>> > > I hope that I'm right: you have to use Enhancement for this option...
>> > >
>> > > see
>> > >
>> http://openjpa.apache.org/docs/latest/manual/manual.html#ref_guide_pc_enhance
>> > > for details.
>> > >
>> > > Best regards,
>> > > Alex
>> > >
>> >
>> > --
>> > View this message in context:
>> http://www.nabble.com/Lazy-loading-not-working.-tf4562936.html#a13040881
>> > Sent from the OpenJPA Developers mailing list archive at Nabble.com.
>> >
>> >
>>
>>
>> --
>> Patrick Linskey
>> 202 669 5907
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/Lazy-loading-not-working.-tf4562936.html#a13047066
Sent from the OpenJPA Developers mailing list archive at Nabble.com.


Mime
View raw message