openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Linskey" <plins...@gmail.com>
Subject Re: Test failures
Date Tue, 21 Aug 2007 01:47:57 GMT
Oops, that was my fault. Should be fixed with r567904.

-Patrick

On 8/20/07, Kevin Sutter <kwsutter@gmail.com> wrote:
> Hi,
> I'm hitting errors similar to the following when testing openjpa-kernel:
>
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> Running org.apache.openjpa.ee.TestWASManagedRuntime
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.079 sec
> Running org.apache.openjpa.util.TestProxyManager
> Tests run: 37, Failures: 0, Errors: 3, Skipped: 0, Time elapsed: 0.453 sec
> <<< FAILURE!
> testCopyBeans(org.apache.openjpa.util.TestProxyManager)  Time elapsed:
> 0.016sec  <<< ERROR!
> java.lang.NullPointerException
>         at org.apache.openjpa.util.TestProxyManager.assertBeansEqual(
> TestProxyManager.java:742)
>         at org.apache.openjpa.util.TestProxyManager.testCopyBeans(
> TestProxyManager.java:716)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(
> NativeMethodAccessorImpl.java:64)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(
> DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:615)
>         at junit.framework.TestCase.runTest(TestCase.java:154)
>         at junit.framework.TestCase.runBare(TestCase.java:127)
>         at junit.framework.TestResult$1.protect(TestResult.java:106)
>         at junit.framework.TestResult.runProtected(TestResult.java:124)
>         at junit.framework.TestResult.run(TestResult.java:109)
>         at junit.framework.TestCase.run(TestCase.java:118)
>         at junit.framework.TestSuite.runTest(TestSuite.java:208)
>         at junit.framework.TestSuite.run(TestSuite.java:203)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(
> NativeMethodAccessorImpl.java:64)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(
> DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:615)
>         at org.apache.maven.surefire.junit.JUnitTestSet.execute(
> JUnitTestSet.java:210)
>         at
> org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(
> AbstractDirectoryTestSuite.java:135)
>         at
> org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(
> AbstractDirectoryTestSuite.java:122)
>         at org.apache.maven.surefire.Surefire.run(Surefire.java:129)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(
> NativeMethodAccessorImpl.java:64)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(
> DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:615)
>         at
> org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(
> SurefireBooter.java:225)
>         at org.apache.maven.surefire.booter.SurefireBooter.main(
> SurefireBooter.java:747)
>
> Do I have to wait until the changes settle down?  Or, am I the only one
> hitting these problems?
>
> Kevin
>


-- 
Patrick Linskey
202 669 5907

Mime
View raw message