openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Prud'hommeaux <mprud...@apache.org>
Subject Re: TestTableGenerator failure
Date Mon, 23 Jul 2007 18:35:43 GMT
Michael-

That did indeed fix it. Thanks!


On Jul 23, 2007, at 11:03 AM, Michael Dick wrote:

> Do you get the error if you run mvn clean before running the test?
>
> I stupidly hardcoded the initial value into the testcase. It looks  
> like
> adding the CLEAR_TABLES flag resolves the problem - should be fixed by
> revision 558815.
>
> On 7/23/07, Marc Prud'hommeaux <mprudhom@apache.org> wrote:
>>
>>
>> Has anyone else been getting the following test failure over the past
>> few days?
>>
>> Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.087
>> sec <<< FAILURE!
>> testInitialValue
>> (org.apache.openjpa.persistence.generationtype.TestTableGenerator)
>> Time elapsed: 0.079 sec  <<< FAILURE!
>> junit.framework.AssertionFailedError: expected:<20> but was:<30>
>>         at junit.framework.Assert.fail(Assert.java:47)
>>         at junit.framework.Assert.failNotEquals(Assert.java:282)
>>         at junit.framework.Assert.assertEquals(Assert.java:64)
>>         at junit.framework.Assert.assertEquals(Assert.java:201)
>>         at junit.framework.Assert.assertEquals(Assert.java:207)
>>         at
>> org.apache.openjpa.persistence.generationtype.TestTableGenerator.test 
>> Ini
>> tialValue(TestTableGenerator.java:45)
>>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native  
>> Method)
>>
>>
>>
>>


Mime
View raw message