openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Idefix <Armea...@hsd.k12.or.us>
Subject Re: Agent not working with current Glassfish V1.x
Date Wed, 06 Jun 2007 15:57:33 GMT

Doesn't anyone have a suggestion on this issue?  Has anyone the combination
of Glassfish / OpenJPA / Spring working?  If so, would you share your
configuration?

Thanks,
Chris


Idefix wrote:
> 
> Hello,
> 
>  
> 
> I am trying to get going with OpenJPA and Spring on Glassfish, but can't
> seem to get the configuration right- I assume at least...
> 
> Anyway, if I use the Spring-Glassfish LoadTimeWeaver my entity beans are
> not working (using current 1.0.0 openjpa snapshot):
> 
>  
> 
> 39170  TekWebPU  INFO   [Thread-27] openjpa.Runtime - Starting OpenJPA
> 1.0.0-SNAPSHOT
> 
> 39311  TekWebPU  WARN   [Thread-27] openjpa.MetaData - The class
> "edu.hsd.tekweb.db.dbo.References" listed in the openjpa.MetaDataFactory
> configuration property could not be loaded; ignoring.
> 
> 39311  TekWebPU  WARN   [Thread-27] openjpa.MetaData - The class
> "edu.hsd.tekweb.db.dbo.Folders" listed in the openjpa.MetaDataFactory
> configuration property could not be loaded; ignoring.
> 
> 39311  TekWebPU  WARN   [Thread-27] openjpa.MetaData - The class
> "edu.hsd.tekweb.db.dbo.Vault" listed in the openjpa.MetaDataFactory
> configuration property could not be loaded; ignoring.
> 
> Illegal access: this web application instance has been stopped already
> (the eventual following stack trace is caused by an error thrown for
> debugging purposes as well as to attempt to terminate the thread which
> caused the illegal access, and has no functional impact)
> 
>>>java.lang.ThreadDeath
> 
>>>        at
> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader
> .java:1332)
> 
>>>        at
> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader
> .java:1292)
> 
>>>        at
> java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
> 
>>>        at
> edu.hsd.tekweb.db.dbo.Folders.pcNewObjectIdInstance(Folders.java)
> 
>>>        at
> org.apache.openjpa.enhance.PCRegistry.newObjectId(PCRegistry.java:130)
> 
>>>        at
> org.apache.openjpa.meta.MetaDataRepository.processRegisteredClass(MetaDa
> taRepository.java:1369)
> 
>>>...
> 
> Unable to generate custom error page, /WEB-INF/sys/error.zul
> 
>>>org.zkoss.zk.ui.UiException: Page not found: /WEB-INF/sys/error.zul
> 
>>>        at
> org.zkoss.zk.ui.http.ExecutionImpl.getPageDefinition(ExecutionImpl.java:
> 216)
> 
> ...
> 
>  
> 
> And if I try to use the OpenJPA agent Glassfish fails to start:
> 
>  
> 
> -Dcom.sun.aas.processLauncher=SE
> 
> -Dcom.sun.aas.installRoot=C:/Sun/SDK
> 
> -Dcom.sun.aas.ClassPathPrefix=
> 
> -Dcom.sun.aas.ClassPathSuffix=
> 
> -Dcom.sun.aas.ServerClassPath=
> 
> -cp
> 
> ;C:/Sun/SDK/lib/appserv-launch.jar
> 
> com.sun.enterprise.server.PELaunch
> 
> start
> 
> debug
> 
> java.lang.reflect.InvocationTargetException
> 
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
> a:39)
> 
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
> Impl.java:25)
> 
>         at java.lang.reflect.Method.invoke(Method.java:597)
> 
>         at
> sun.instrument.InstrumentationImpl.loadClassAndStartAgent(Instrumentatio
> nImpl.java:323)
> 
>         at
> sun.instrument.InstrumentationImpl.loadClassAndCallPremain(Instrumentati
> onImpl.java:338)
> 
> Caused by: java.lang.NoClassDefFoundError:
> org/apache/commons/lang/exception/NestableRuntimeException
> 
>         at java.lang.ClassLoader.defineClass1(Native Method)
> 
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
> 
>         at
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
> 
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
> 
>         at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
> 
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
> 
>         at java.security.AccessController.doPrivileged(Native Method)
> 
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> 
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> 
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
> 
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> 
>         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
> 
>         at
> org.apache.openjpa.enhance.PCEnhancerAgent.premain(PCEnhancerAgent.java:
> 47)
> 
>         ... 6 more
> 
> Exception in thread "main" 
> 
> Could anyone please provide some info as to how to get this working...
> 
>  
> 
> Thanks,
> 
> Chris
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Agent-not-working-with-current-Glassfish-V1.x-tf3874964.html#a10991518
Sent from the OpenJPA Developers mailing list archive at Nabble.com.


Mime
View raw message