openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "catalina wei" <catalina....@gmail.com>
Subject Re: xml store help?
Date Fri, 11 May 2007 22:42:46 GMT
Anh,
I have created issue OPENJPA-238 for keeping track of this problem.
The patch that I sent to you is also attached under OPENJPA-238.

Catalina

On 5/8/07, Ngo, Anh (ISS Southfield) <hngo@us.ibm.com> wrote:
>
>  Hello,
>
>
>
> I am evaluating openJPA to use for our current project.  It works fine for
> our need with database.  But I am having problem with the XMLStoreManager.
> I have two simple objects – Customer and User.  Customer can have multiple
> users.  I look at the object store in xml file.  It stored like this:
>
>
>
> <?xml version="1.0" encoding="UTF-8"?>
>
> <extent>
>
>     <object class="net.iss.mss.jpa.examples.remedy.Customer" oid="1"
> version="0">
>
>         <field name="customerId">
>
>             "1"
>
>         </field>
>
>         <field name="customerName">
>
>             "customer1"
>
>         </field>
>
>         <field name="users">
>
>             <element>
>
> *                org.apache.openjpa.util.StringId:1*
>
>             </element>
>
>             <element>
>
> *                org.apache.openjpa.util.StringId:2*
>
>             </element>
>
>         </field>
>
>     </object>
>
> </extent>
>
>
>
> Shoud the Users element store User object?  The XMLStoreManager failed to
> load data in because it doest not know how to create* this
> object:                org.apache.openjpa.util.StringId:1*
>
> * *
>
> Please help…
>
> * *
>
> I attached my orm.xml and persisentene.xml for your references.
>
>
>
>
>
> Sincerely,
>
>
>
> * *
>
>
>
> Anh Ngo
>
> Senior Application Programmer
>
> IBM Internet Security Systems
>
> 248 226 9059
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message