openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig L Russell <Craig.Russ...@Sun.COM>
Subject Re: [VOTE] Packaging with maven
Date Mon, 07 May 2007 16:45:41 GMT
I agree that it doesn't matter what we call the openjpa-parent  
directory. Trunk is ok.

But I do think we should rename the openjpa-all to openjpa to be  
consistent with the artifact name and location in the directory  
structure. The difference in my mind is that the openjpa-parent isn't  
an artifact that we ship.


On May 7, 2007, at 9:26 AM, Marc Prud'hommeaux wrote:

>
> Patrick raises a good point. Also, we might also be able to just  
> have the "openjpa" aggregate jar module be in a sub-directory named  
> "openjpa" without having to rename the parent module's enclosing  
> directory, since I don't think Maven much cares what the name of  
> the directory in which the parent module resides (I doubt it even  
> ever looks at it). I.e., it would be located at http:// 
> svn.apache.org/repos/asf/openjpa/trunk/openjpa/openjpa.

I'm confused now. The trunk has openjpa-kernel, openjpa-all, and all  
the other directories each of which is a maven project. I'd propose  
simply renaming trunk/openjpa-all to trunk/openjpa to match the  
artifactId of the aggregate jar.

And we still need to decide on the artifactId and directory name for  
openjpa-project.

Craig
>
> How does that sound?
>
>
>
> On May 7, 2007, at 9:15 AM, Patrick Linskey wrote:
>
>> I think it makes sense to rename dirs as appropriate. Remember that
>> once we graduate, we'll be moving repositories anyways, so it would
>> seem like a good opportunity to make structural changes.
>>
>> -Patrick
>>
>> On 5/7/07, Michael Dick <michael.d.dick@gmail.com> wrote:
>>> +1
>>>
>>> What would the impact be if we renamed openjpa-all to openjpa?
>>>
>>> We could change our checkout instructions to read
>>> svn co http://svn.apache.org/repos/asf/incubator/openjpa/ 
>>> trunkopenjpa-parent
>>> and then the directories match the artifactId's in pom.xml.
>>>
>>> The only reason I think this is worth doing is to avoid confusion  
>>> for new
>>> developers down the road. It's just one more thing that we have  
>>> to remember
>>> and explain. Maybe there's an impact to changing the directory  
>>> name that I
>>> missed though.
>>>
>>> -Mike
>>>
>>> On 5/6/07, Marc Prud'hommeaux <mprudhom@apache.org > wrote:
>>> >
>>> >
>>> > Poking around the ActiveMQ pom.xml files, I notice that you can  
>>> have
>>> > a different artifactId than the module name (i.e., directory)  
>>> you are
>>> > in. I hadn't known you could do this.
>>> >
>>> > Currently, our artifacts name are:
>>> >
>>> >    trunk/pom.xml: openjpa
>>> >    trunk/openjpa-all/pom.xml: openjpa-all
>>> >    trunk/openjpa-project/pom.xml: openjpa-project
>>> >
>>> > We could change these to:
>>> >
>>> >    trunk/pom.xml: openjpa-parent
>>> >    trunk/openjpa-all/pom.xml: openjpa
>>> >    trunk/openjpa-project/pom.xml: apache-openjpa
>>> >
>>> > I've tested this out, and it results in the openjpa aggregate jar
>>> > being named "openjpa-VERSION.jar", the dependency being simply  
>>> named
>>> > "openjpa", and the assembly is named "apache-openjpa- 
>>> VERSION.zip ".
>>> > None of the directories needed to be renamed. I've attached the  
>>> patch
>>> > that does this to https://issues.apache.org/jira/browse/ 
>>> OPENJPA-194
>>> >
>>> > Since this will mess up people who currently have maven  
>>> dependencies
>>> > on OpenJPA (i.e., people who depend on "openjpa-all" will now  
>>> need to
>>> > depend on "openjpa"), we should probably get this hammered out  
>>> before
>>> > leaving incubation. So I've gone ahead and turned the [DISCUSS]  
>>> into
>>> > a [VOTE] to see if we should go ahead and do this.
>>> >
>>> > A vote of +1 means we should do the renaming, -1 means we  
>>> should not,
>>> > and 0 means "don't care". The vote will remain open until  
>>> Wednesday
>>> > May 9th at 23:59 GMT.
>>> >
>>> >
>>> >
>>> >
>>> > On May 4, 2007, at 6:55 AM, Michael Dick wrote:
>>> >
>>> > > Some comments below
>>> > >
>>> > > On 5/4/07, Craig L Russell <Craig.Russell@sun.com > wrote:
>>> > >>
>>> > >> I'd like reopen the discussion on how to package and name our
>>> > >> artifacts. I think the current setup could be improved, to  
>>> give a
>>> > >> better experience for users who might not be using maven for
>>> > >> dependency management. It's easy for us to change now before
>>> > >> graduation because once we graduate, people will need to  
>>> update their
>>> > >> dependencies anyway so there are no backward compatibility  
>>> issues.
>>> > >>
>>> > >> The name of the single jar that has all of the openjpa stuff  
>>> in it
>>> > >> except for the documentation and examples is currently called
>>> > >> openjpa-
>>> > >> all. This name is confusing because unless they RTFM, people  
>>> don't
>>> > >> really know that it's not all the code you need, just all  
>>> the jpa
>>> > >> code. So I'd like to call this artifact openjpa.
>>> > >
>>> > >
>>> > > +1
>>> > >
>>> > > But we already have a project with that name, and that  
>>> project builds
>>> > >> the distributions. So I'd rename the current openjpa to  
>>> openjpa-dist.
>>> > >> Its ultimate destination in the Apache mirror structure is  
>>> under
>>> > >> www.apache.org/dist/openjpa once we graduate, so having dist  
>>> in the
>>> > >> project name helps understanding that this project builds the
>>> > >> artifacts that go into dist. Separate from the artifacts  
>>> that are
>>> > >> published via maven.
>>> > >
>>> > >
>>> > > +1
>>> > >
>>> > > Finally, the openjpa-all jar includes its subcomponents as
>>> > >> dependencies. I think this is wrong, since you end up with a  
>>> class
>>> > >> path with openjpa-all.jar as well as openjpa-kernel.jar and  
>>> all the
>>> > >> others.
>>> > >
>>> > >
>>> > > I would like to change this too. I did a little experimenting  
>>> and
>>> > > it looks
>>> > > like the dependencies aren't needed in openjpa-all, but they are
>>> > > needed for
>>> > > openjpa-project (to populate the lib directory). Moving the
>>> > > dependencies
>>> > > into openjpa-project should be safe.
>>> > >
>>> > > We're also going to need to change the deploy logic to strip  
>>> out the
>>> > > -project suffix from the zip files. We've talked about it before
>>> > > when I was
>>> > > releasing 0.9.7 (and before that when Marc was working on  
>>> 0.9.6),
>>> > > but I
>>> > > haven't had time to look into it. It should be fairly easy to  
>>> make the
>>> > > change.
>>> > >
>>> > >
>>> > > Thoughts?
>>> > >>
>>> > >> Craig
>>> > >>
>>> > >> Craig Russell
>>> > >> Architect, Sun Java Enterprise System http://java.sun.com/ 
>>> products/
>>> > >> jdo
>>> > >> 408 276-5638 mailto:Craig.Russell@sun.com
>>> > >> P.S. A good JDO? O, Gasp!
>>> > >>
>>> > >>
>>> > >>
>>> > > -Michael Dick
>>> >
>>> >
>>>
>>
>>
>> -- 
>> Patrick Linskey
>> 202 669 5907
>

Craig Russell
Architect, Sun Java Enterprise System http://java.sun.com/products/jdo
408 276-5638 mailto:Craig.Russell@sun.com
P.S. A good JDO? O, Gasp!


Mime
View raw message