openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Linskey (JIRA)" <j...@apache.org>
Subject [jira] Commented: (OPENJPA-243) IntelliJ IDEA plugin to integrate OpenJPA enhancer into build process
Date Mon, 21 May 2007 23:06:16 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-243?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12497624
] 

Patrick Linskey commented on OPENJPA-243:
-----------------------------------------

The plugin as of r540340 integrates the OpenJPA enhancer with IntelliJ IDEA's build process.

It requires IntelliJ IDEA 7.0M1 or more recent. It also requires a recent build of OpenJPA,
due to classloader issues in the PCEnhancer. The plugin does not currently validate that it
has a satisfactory OpenJPA version.

The plugin does not bundle OpenJPA jars inside it; this is intentional. In order to use the
plugin, you must have OpenJPA in your module's classpath (which is already a requirement for
running any tests with OpenJPA). The plugin will pick up the OpenJPA version in your module
and use it. If OpenJPA is not available in the classpath, the plugin should gracefully short-circuit.

The plugin will run the enhancer on all persistent types (@Entity, @MappedSuperclass, @Embeddable)
in certain of the persistence units in the module being compiled. It will only run on persistence
units that either do not define a persistence provider or specify the OpenJPA persistence
provider.

> IntelliJ IDEA plugin to integrate OpenJPA enhancer into build process
> ---------------------------------------------------------------------
>
>                 Key: OPENJPA-243
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-243
>             Project: OpenJPA
>          Issue Type: New Feature
>          Components: kernel, third-party
>    Affects Versions: 0.9.0, 0.9.6, 0.9.7
>         Environment: IntelliJ IDEA 7.0M1, OpenJPA 0.9.8-SNAPSHOT
>            Reporter: Patrick Linskey
>         Assigned To: Patrick Linskey
>             Fix For: 0.9.8
>
>         Attachments: OpenJPA-0.1.zip
>
>
> It would be nice if OpenJPA's enhancer could be automatically invoked when compiling
persistent types in IntelliJ IDEA.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message