openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Prud'hommeaux <mprud...@apache.org>
Subject Re: java.util.MissingResourceException: org.apache.openjpa.persistence.PersistenceProductDerivation:java.io.IOException
Date Wed, 02 May 2007 10:29:56 GMT

It might be that the JDK 1.5 beta you were using doesn't support XML  
Schema (which is used by the JPA XML format)...


On May 2, 2007, at 10:42 AM, Philippe Alexis wrote:

> On 5/2/07, Patrick Linskey <plinskey@gmail.com> wrote:
>>
>> Could you run ant with the '-e' option to get full stack traces?
>>
>> Also, my guess would be that you've got some sort of security policy
>> prohibiting OpenJPA from reading resources.
>>
>> -Patrick
>
>
> Thanks. Ant's -e option didn't yield a more verbose stack trace,  
> but the
> hint about security policy
> prompted me to try on an XP machine instead. After updating from
> jdk1.5.0_beta2 to update 11
> the download works out of the box; not sure what's wrong with Java  
> on my
> Win2K installation.
>
> J-Philippe.
>
>
> On 5/1/07, Philippe Alexis <philippe.alexis@gmail.com> wrote:
>> > > Hello Everyone,
>> > >
>> > > Here's what I'm getting when I follow the 5min quick start guide
>> strictly,
>> > > under both Eclipse 3.1.1 and 3.2,
>> > > and under Ant on Cygwin, using jdk1.5.0_11-b03:
>> > >
>> > >
>> ===================================================================== 
>> ============
>> > >
>> > > Buildfile: D:\Programming\Java\openjpa-
>> > > project-0.9.7-incubating\examples\hellojpa\build.xml
>> > > compile:
>> > > run:
>> > >      [java] java.lang.reflect.InvocationTargetException
>> > >      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0 
>> (Native
>> Method)
>> > >      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(
>> > > NativeMethodAccessorImpl.java:39)
>> > >      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(
>> > > DelegatingMethodAccessorImpl.java:25)
>> > >      [java] at java.lang.reflect.Method.invoke(Method.java:585)
>> > >      [java] at
>> sun.instrument.InstrumentationImpl.loadClassAndCallPremain(
>> > > InstrumentationImpl.java:141)
>> > >      [java] Caused by: java.util.MissingResourceException:
>> > >
>> org.apache.openjpa.persistence.PersistenceProductDerivation:java.io.I 
>> OException:
>> > > org.xml.sax.SAXNotRecognizedException: Property:
>> > > http://java.sun.com/xml/jaxp/properties/schemaLanguage
>> > >      [java] at
>> org.apache.openjpa.lib.conf.ProductDerivations.reportErrors
>> > > (ProductDerivations.java:326)
>> > >      [java] at  
>> org.apache.openjpa.lib.conf.ProductDerivations.load(
>> > > ProductDerivations.java:316)
>> > >      [java] at
>> org.apache.openjpa.lib.conf.ProductDerivations.loadDefaults
>> > > (ProductDerivations.java:283)
>> > >      [java] at
>> > > org.apache.openjpa.lib.conf.Configurations.populateConfiguration(
>> > > Configurations.java:298)
>> > >      [java] FATAL ERROR in native method: processing of - 
>> javaagent
>> failed
>> > >      [java] at  
>> org.apache.openjpa.enhance.PCEnhancerAgent.premain(
>> > > PCEnhancerAgent.java:49)
>> > >      [java] ... 5 more
>> > >      [java] Exception in thread "main"
>> > >
>> > > BUILD FAILED
>> > > D:\Programming\Java\openjpa-
>> > > project-0.9.7-incubating\examples\build.xml:67: Java returned: 1
>> > >
>> > > Total time: 1 second
>> > >
>> > >
>> ===================================================================== 
>> ============
>> >
>> >
>> > I'm not sure what I'm doing wrong. I'm still stuck in the  
>> starting block
>> > here. It's probably related to some missing
>> > XML file, I'd guess.. but the default download is self-contained  
>> with
>> > everything required for the quickie included, isn't it?
>> >
>> > J-Philippe.
>> >
>>
>>
>> --
>> Patrick Linskey
>> 202 669 5907
>>


Mime
View raw message