openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Linskey" <plins...@bea.com>
Subject RE: Open JPA error-Could not locate metadata for the class using alias
Date Thu, 26 Apr 2007 17:29:21 GMT
> Understood. Right now I'm in the connection debate: toplink 
> cannot use less than 2, so each of my fat clients will have 3 
> open (1 it already has). So the decision is still open. It 
> appears that using a business model this way is not something 
> that is done often.

In what sense? In my experience, it's quite common to have some JDBC
code and some JPA code in non-trivial applications; connection
integration between the two different environments certainly is not
uncommon.

Note that if you plan to be accessing the same data in both places
(which is a bit less common), you should take care to flush your EM when
going from JPA to JDBC, and take corresponding precautions after going
from JDBC back to JPA work.

As David pointed out, if you're using table-based sequences in OpenJPA,
then, depending on your connection retain mode and flushing
characteristics, OpenJPA may need a second connection from time to time.
If you ensure that sufficient sequence values are available before doing
something that forces an EM to hold onto a connection, then you can
avoid this.

-Patrick

-- 
Patrick Linskey
BEA Systems, Inc.
_______________________________________________________________________
Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it. 

> -----Original Message-----
> From: tbee [mailto:tbee@tbee.org] 
> Sent: Thursday, April 26, 2007 10:17 AM
> To: open-jpa-dev@incubator.apache.org
> Subject: RE: Open JPA error-Could not locate metadata for the 
> class using alias
> 
> 
> 
> 
> Patrick Linskey wrote:
> > 
> > FYI, once I commit a fix to OPENJPA-229, you'll be able to use the 
> > same class names once again. Sorry about that bug.
> > 
> 
> Understood. Right now I'm in the connection debate: toplink 
> cannot use less than 2, so each of my fat clients will have 3 
> open (1 it already has). So the decision is still open. It 
> appears that using a business model this way is not something 
> that is done often.
> --
> View this message in context: 
> http://www.nabble.com/Open-JPA-error-Could-not-locate-metadata
> -for-the-class-using-alias-tf3561516.html#a10204857
> Sent from the open-jpa-dev mailing list archive at Nabble.com.
> 
> 

Notice:  This email message, together with any attachments, may contain information  of  BEA
Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,
 copyrighted  and/or legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient, and have received
this message in error, please immediately return this by email and then delete it.

Mime
View raw message