openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Linskey" <plins...@bea.com>
Subject RE: Open JPA error-Could not locate metadata for the class using alias
Date Wed, 25 Apr 2007 06:27:07 GMT
> What I'm wondering about: when running under Toplink there is 
> an output "alias defaults to ....". Is there something that 
> Toplink assumes about this alias that actually should be 
> configured and where OpenJPA has problems with?

No... the alias should default to the short name of the class; that
behavior is defined in the spec.

> I can just "upload file" the example code? How to solve the 
> missing Informix database?

I don't think that uploading to this mailing list works; the easiest
thing to do is to create a JIRA issue and attach the jar / zip of the
problem there. If you'd rather not create a JIRA account, you can send
the code to pcl at apache dot org, and I'll attach it to a new issue for
the group's perusal.

-Patrick

-- 
Patrick Linskey
BEA Systems, Inc.
_______________________________________________________________________
Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it. 

> -----Original Message-----
> From: tbee [mailto:tbee@tbee.org] 
> Sent: Tuesday, April 24, 2007 11:24 PM
> To: open-jpa-dev@incubator.apache.org
> Subject: RE: Open JPA error-Could not locate metadata for the 
> class using alias
> 
> 
> 
> 
> Patrick Linskey wrote:
> > 
> > Could you try out the almost-final OpenJPA 0.9.7 bits instead? The 
> > candidate (currently being voted on) is at 
> > 
> http://people.apache.org/~mikedd/staging-repository/org/apache/openjpa
> > /o 
> > 
> penjpa-project/0.9.7-incubating/openjpa-project-0.9.7-incubati
> ng-binary.
> > zip
> > 
> > If that doesn't work out, could you package up an example for us to 
> > try out against the latest code?
> > 
> 
> 47  reinders  INFO   [main] openjpa.Runtime - Starting OpenJPA
> 0.9.7-incubating
> 172  reinders  INFO   [main] openjpa.jdbc.JDBC - Using 
> dictionary class
> "org.apache.openjpa.jdbc.sql.InformixDictionary".
> Exception in thread "main" <0.9.7-incubating fatal user error>
> org.apache.openjpa.persistence.ArgumentException: Could not 
> locate metadata for the class using alias "Article". 
> Registered alias mappings:
> "{Article=null}"
> 
> What I'm wondering about: when running under Toplink there is 
> an output "alias defaults to ....". Is there something that 
> Toplink assumes about this alias that actually should be 
> configured and where OpenJPA has problems with?
> 
> I can just "upload file" the example code? How to solve the 
> missing Informix database?
> --
> View this message in context: 
> http://www.nabble.com/Open-JPA-error-Could-not-locate-metadata
> -for-the-class-using-alias-tf3561516.html#a10175078
> Sent from the open-jpa-dev mailing list archive at Nabble.com.
> 
> 

Notice:  This email message, together with any attachments, may contain information  of  BEA
Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,
 copyrighted  and/or legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient, and have received
this message in error, please immediately return this by email and then delete it.

Mime
View raw message